User GuidesSnapGene User Guide Editing SequencesEdit a Sanger (.ab1, .scf or .ztr) Trace File

Edit a Sanger (.ab1, .scf or .ztr) Trace File

How do I edit a  Sanger chromatogram?

Nucleotide base calls associated with Sanger trace files are called by the DNA Sequencing Instrument software. Ambiguous or heterozygous peaks or compressed regions may sometimes be called incorrectly.

SnapGene does not parse or recall sequence traces.  You can correct miscalls by manually editing a trace file.

  • SnapGene can read ABI trace files (.ab1), SCF (.scf) or ZTR (.ztr) format trace files
  • Miscalls due to compression of peaks are more likely at the start of a sequence
  • Miscalls due to merged peaks are more likely towards the end of a sequence

De novo assembly of overlapping Sanger traces via Tools → Assemble Contigs (see De Novo Assembly of Sanger Sequences) maybe more reliable if you edit and correct Sanger reads prior to assembly.

Open a Trace file

Open a trace file in SnapGene.

Turn on "Show quality values" to see the graph of "Phred" quality score for each based call. This may assist in assessing the reliability each peak call.

Use the scroll bar to visually examine the sequence.

Correct Error Due to Compressions

In the above example compression of A and T peaks near the start of a sequence are called as a single N.

Select the "N" and type the first replacement to open the "Insert Bases" dialog. Enter the replacement sequence. Click Insert to complete the edit.

Use lower case when manually editing so that they can be identified at a later date.

Correct Heterozygous Positions

Select mixed positions that have been called as a N. Type the replacement IUPAC code for the mixed position. In the above example, equally sized A and G peaks have been called as a N. Replace the N with "R" (A or G).

Correct all ambiguous/heterozygous positions.

Click Tools → Letter Codes to see a summary of IUPAC codes used to describe ambiguous nucleotide positions.

Manually Delete Low Quality or Unwanted Ends

Click and drag to select a region for removal , then click Edit → Delete Bases (or hit the "delete" key) to remove the base calls.

The SnapGene Align to Reference Sequence and Assemble Contigs tools automatically trims and/or hides low quality ends of traces. In most cases you should not need to manually trim ends.

Save the Edited Trace File

Click File → Save to save the edited trace to an appropriate location on your computer. Note that edited trace files must be saved in .SCF or .ZTR format to retain the chromatogram information.