User GuidesSnapGene User Guide Editing SequencesExtract a Region in a Sequence to a New File

Extract a Region in a Sequence to a New File

How do I extract a part of a larger sequence to a new file?

Select the Region

Open a source sequence file.

In Map view or Sequence view select the region of interest by one of the following methods:

  • Click and drag to select a region
  • Click to the left of the new first position then shift-click at the last position
  • If the region is already defined by a feature then click on the feature to select it
  • If the region is bounded by two or more features, click on the leftmost feature, then shift-click on the rightmost feature

Extract the Selected Region to a New File

Click File → New File from Selection....

Enter a name for the new file, choose to "Preserve original original numbering" or leave this option unchecked to reset the first nucleotide coordinate to 1. Click New File to create a new (unsaved) file comprising the selected region.

Save the File

Click File → Save to save the sequence.

View the File

The extracted fragment will be blunt ended and will not have 5' phosphates. If you wish to phosphorylate the 5' ends then click Edit → Edit DNA Ends....